Session ended unexpectedly

Table of content

Error Code

  • anynet_unknown
  • win32_10054
  • win32_10060
  • win32_10061

Cause

This error occurs when an external factor disrupts the AnyDesk connection. Here are some common reasons why this might happen:

  • The remote device is powered off unexpectedly.
  • The local or remote device loses internet access.
  • A security software (firewall, antivirus, anti-ransomware), either on the local or remote device, ends the AnyDesk session.
  • A network-level security solution (router, proxy, VPN, etc.), either on the local or remote device, blocks or disconnects the AnyDesk session.

Fix

Please make sure your firewall on both the local and remote devices as well as networking hardware such as routers do not interfere with AnyDesk’s connection.

Check security & firewall settings

Adjust connection settings in the client

  1. Go to Settings > Connection > General.
  2. Clear the Allow direct connections checkbox.
  3. If the issue persists, add /np to the AnyDesk ID or Alias (for example, 000111222/np or test@ad/np) when connecting.

If your session disconnects at predictable intervals (e.g., every 30 seconds or 10 minutes), it’s likely due to security software flagging the connection:

  • Review the logs in your security software for blocked or terminated connections.
  • Add AnyDesk to your software’s trusted applications list or create a specific rule to maintain the session.

A numeric or alphanumeric code that indicates a specific issue or status in the AnyDesk application during use.

A built-in feature that creates a secure, private connection between local and remote devices. It enhances security by linking only the two devices directly, without allowing access to other devices on either network.

A unique number automatically assigned to each installed AnyDesk app. It’s used to identify the device and connect to it remotely.

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